Quantcast
Channel: User user2023861 - Code Review Stack Exchange
Viewing all articles
Browse latest Browse all 35

Answer by user2023861 for Census data from file input (text)

$
0
0

Some ideas:

You if conditions can be simplified. The following to blocks are logically equivalent. This version is yours with only if statements:

if (ageData[i] > 0 && ageData[i] <= 18){    ageGroup[0] = ageGroup[0] + 1;}if (ageData[i] > 18 && ageData[i] <= 30){    ageGroup[1] = ageGroup[1] + 1;}

This version uses if-else statements and is equivalent as long as ageData[i] is positive:

if (ageData[i] > 0 && ageData[i] <= 18){    ageGroup[0] = ageGroup[0] + 1;}else if (ageData[i] <= 30) //I removed the "ageData[i] > 18 && "{    ageGroup[1] = ageGroup[1] + 1;}

A more advanced technique would involve storing the age ranges in a data structure so that you can edit them more easily. You could use a dictionary that maps maximum ages to counts.


You should be disposing your stream objects: fstream and inFile. Better yet, read your whole file into a string with a single line like this:

string[] contents = System.IO.File.ReadAllLines(@"c:\path\to\file.txt");

This uses the verbatim string literal @. See here. Your loop will change as a result:

foreach(string line in contents){    fields = line.Split(',');}

If you haven't learned foreach loops yet, you can use a for loop like this:

for(int lineNumber = 0; lineNumber < contents.Length; lineNumber++{    fields = contents[lineNumber].Split(',');    //etc.}

You haven't said whether you've learned to use generic Lists or not. Your arrays hold 1000 items. If your input has more than 1000 items, you'll get an exception. If you have learned about Lists, you should use them instead because they automatically re-size themselves when they run out of room.

Instead of:

int[] ageData = new int[1000];ageData[i] = int.Parse(fields[0]);

You do:

List<int> ageData = new List<int>();ageData.Add(int.Parse(fields[0]));  //you have to add an int to the list before you can use it

You have numbers sprinkled around everywhere. This is a problem for readability and maintenance. What happens if they add a district? I see two changes you'd have to make. What about if the age and gender columns are reversed? It's not so clear what changes you'd need to make to account for that.

Create constants like this:

const int COLUMN_AGE = 0;const int ARRAY_SIZE = 1000;//etc.

And then do this:

int[] ageData = new int[ARRAY_SIZE];ageData[i] = int.Parse(fields[COLUMN_AGE]);//etc.

Is there some reason you didn't use string formats for the following line?

Console.WriteLine("District   "+ x +"   has   "+ countDist[x] +"   citizens");

You can use this:

Console.WriteLine("District   {0}   has   {1}   citizens", x, countDist[x]);

These lines are a headache:

for (int x = 1; x <= 22; x++)    for (int y = 0; y < districtData.Length; y++)        if (districtData[y] == x)            countDist[x]++;

You should get in the habit of using braces for all for loops and all but the simplest if statements. Also, the variable names x and y aren't very descriptive. Why not rename x to districtCount, and rename y to districtNumber?

for (int districtCount = 1; districtCount <= 22; districtCount++){    for (int districtNumber = 0; districtNumber < districtData.Length; districtNumber++)    {        if (districtData[districtNumber] == districtCount)        {            countDist[districtCount]++;        }    }}

Visual Studio makes it easy to rename variables. Right click on one and go Refactor > Rename. Or click F2. Don't be afraid of long variable names. Because of Intellisense, you really only need to type them out once.


Viewing all articles
Browse latest Browse all 35

Trending Articles



<script src="https://jsc.adskeeper.com/r/s/rssing.com.1596347.js" async> </script>